• How to Install PHP 5.3 on Windows

    PHP 5.3 Installation

    Windows PHP distributions are now available from http://windows.php.net/download/. Installing PHP as an Apache 2.2 module using the Apache Lounge build, so you should download the VC9 x86 Thread Safe Zip file.

    installing php 5.3

    General note:
    Download the VC6 builds if you are using the standard Apache.org web server. The VC9 builds should be used for the Apache Lounge binaries or IIS.

    A Thread Safe version should be used if you install PHP as an Apache module. The Non Thread Safe version should be used if you install PHP as a CGI binary.

    You can now follow the instructions at How to Install PHP on Windows from step 2 onwards. Note that, in step 3, php.ini-recommended is now named php.ini-development; you still need make a copy and rename it php.ini.

    If you have previously defined a working PHP configuration file, a tool such as WinMerge can help you compare and copy existing values to your new php.ini file.

    PHP 5.3 Zend Extension Installation

    When I install ZendGuardLoader for php 5.3 on Windows, I found that zend_extension can only workred  in VC9 version and must be used as CGI/FastCGI for Apache2.

    If successful  installed , you will see the following info of phpinfo() output:

    This program makes use of the Zend Scripting Language Engine:
    Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    
    with Zend Guard Loader v3.3, Copyright (c) 1998-2010, by Zend Technologies
    

    Here is my php.ini config:

    ; for php 5.3.x and later
    zend_loader.enable=1
    zend_extension=D:\app\vc9\php-loader\ZendGuardLoader\php5.3.x\ZendLoader.dll
    
    ; Disable license checks (for performance reasons)
    ;zend_loader.disable_licensing=0
    ; The Obfuscation level supported by Zend Guard Loader.
    ; The levels are detailed in the official Zend Guard Documentation. 0 - no obfuscation is enabled
    ;zend_loader.obfuscation_level_support=3
    ; Path to where licensed Zend products should look for the product license.
    ; For more information on how to create a license file, see the Zend Guard User Guide
    ;zend_loader.license_path=
    

    PHP 5.3 Other Extension Installation

    Such as SourceGuardian and ioncube, they also used as Thread Safe or Non Thread Safe way.

    The following is my config for Non Thread Safe way used for php cgi config way.

    ; SourceGuardian
    extension=D:\app\vc9\php-loader\SourceGuardian\ixed.5.3.win
    
    ; ioncube
    zend_extension=D:\app\vc9\php-loader\ioncube\ioncube_loader_win_5.3.dll
    

    Above some part is from: http://blogs.sitepoint.com/2009/07/07/install-php53-windows and thanks to Craig Buckler

    php-loader for php 5.3 windows can download here: php-loader for php 5.3 windows